Recent Changes - Search:

HomePage

PmWiki

pmwiki.org

Newton

All of the libraries required for the toolkit are installed already on the cluster.

Add following lines to your .bashrc

module purge
module load matlab
module load mkl-2018 boost-1.66 gcc-4.9.4 gnu

Order matters!

The actual configure line depends on how you want to use MKL. For a basic sequential mode (no threading), try

./mptoolkit/configure --with-boost=/usr/local/boost/1.66/ \
   --with-blas="-L/${MKLROOT}/lib/intel64 -Wl,--no-as-needed -lmkl_gf_lp64 -lmkl_sequential -lmkl_core -lpthread -lm -ldl" \
   CXXFLAGS="-Ofast -march=native -flto "  \
   F77="gfortran"

you may use —prefix=/home/username/bin/ to specify the installation directory! Good luck.

Edit - History - Print - Recent Changes - Search
Page last modified on October 06, 2018, at 12:43 AM